Zola Serve - CLI with skip folder


I’m working with +50K posts and is hard to wait for serve re-load when something is changed.

Is possible setup the places of the Listening for changes of the command zola serve?


Have you tried zola serve --fast?

Thanks for your answer.
I tried but is not better, the same slow way in my case.

What are you changing, a template? --fast only renders the current markdown being edited. If you change the templates we do need to re-render everything

Wow good point! Yes, I’m changing the templates.

Sounds like a solution might be renaming those +50K .md files for a bit while sprucing up templates.

for f in *.md; do mv -- "$f" "${f%.md}.md-keep"; done

Thanks Adrian.

Yes, I’m doing it. Moving the folder to outside content directory:

mv content/blog blog

And to back:

mv blog content/blog

It works, but I need to move every time, if the option to skip was available would be more simple. But its ok.

Can you test on a few .md files.

I often use a Makefile with a different config file.
Perhaps you can take advantage of the ignored_content directory in the config file. Remove it for config_prod

# A list of glob patterns specifying asset files to ignore when the content
# directory is processed. Defaults to none, which means that all asset files are
# copied over to the `public` directory.
# Example:
# ignored_content = ["*.{graphml,xlsx}", "temp.*", "**/build_folder"]


	$(ZOLA) build

	$(ZOLA) --config $(CONFIG_PROD) build

Thank you very much Adrian!

I managed to do this, now I have the second config file to handle the prod settings.
I didn’t need the Makefile, I just configured my prod build to use the new configuration and everything is fine.
I took advantage and cleaned up and organized my config file to make it simpler and easier.
My problem has now been resolved, thank you very much

All right. Good stuff.
But come one. Embrace the old school.

1 Like