Themes not being applied 0.16.1

Running zola serve locally generates the site how I would expect it to look but when deployed to netlify, the display is all wrong (it doesn’t seem the theme is applied). I tried zola build and used the caddy webserver to serve the public folder generated and I get similar results to netlify. I’ve followed the config.toml guidance to put theme before the dicts (extra) and have even tried copying the theme files into my main project but the theme is still not applied when served through netlify or caddy webserver. Only zola serve produces the right display

zola serve and zola build call the same code, do you have an example repo I can look at?

Same here. Here’s my repo GitHub - vcrn/index45-site, and here’s how it turns out: Here’s how it’s generated locally:

You don’t have a TLD in your base url: index45-site/config.toml at main · vcrn/index45-site · GitHub

1 Like

Thank you so much! It also solved another bug I couldn’t figure out. And thank you for all the work on Zola, it’s great!

hi Keats, this is the repo I am using with the corresponding site here(dns may still be propagating for the fqdn inveteratenovitiate_dot_com). I do seem to have base_url configured in config.toml.

Seems it got resolved once DNS propagated.