I tried to use zola

Hi, so I tried to use zola with a theme but that theme down right refused to work with GitHub pages and wasn’t being used or seen during the build and deploy, Ill send a link here so that someone can see and explain to me why that’s the case and possibly help me get it working, GitHub - m0thman70/doms-websitev2.3 basically the site looks nothing like what it was shown Halve-Z Zola theme here is the link the website


And I attached and image of how it’s supposed to look

I’ve taken a look and I can’t see what’s wrong.

The GitHub Action correctly creates the artifact with all the files (CSS etc) that later appear to be missing. Further, all files are indeed there: GitHub - m0thman70/doms-websitev2.3 at gh-pages

Perhaps it’s an issue with the repo settings regarding Pages? If you visit your repo > Settings > Pages, it should look like:

Source: Deploy from a branch
Branch: gh-pages / (root)

Yeah that’s what it looks like and it is like that, again it’s just the CSS isn’t showing for some reason

Ah, I figured it out. The files (CSS and all) were there, but the HTML was looking for them on the wrong place.

Where the file is:
https://m0thman70.github.io/doms-websitev2.3/main.css

Where the page was trying to load the file:
https://m0thman70.github.io/main.css

The reason for this was the theme code. I’ve done some changes on my fork and managed to fix it. See a live demo (repo).

I have created a PR. If it’s merged, you’ll need to update the theme on your end and the issue should be solved.

Mate you’re honestly a saint and I don’t know how I could thank you for this, I knew it was something with the CSS not being seen but I didn’t expect that it was because it wasnt finding the files correctly, now that I know that I should be able to use this again and have it work on GitHub pages (current theme I’m using is missing a few things that I want so)

1 Like

Happy to help!

Hi mate, I just forked your thing, with the fix and it’s still not working I honestly don’t know what’s going on

Nvm I just fixed it Lmao

Did you forget to use the proper branch? :stuck_out_tongue:

:tada: