SOLVED: Troubleshooting Missing Syntax

I am trying to follow the instructions on adding an additional syntax to my site but for some reason things aren’t lining up I am hoping someone can point me in the right direction.

I’ve updated my config.toml to have the entry extra_syntaxes_and_themes = ["syntaxes"], and then setup that directory with my syntax.

tree ./syntaxes 
└── llvm.sublime-syntax

where the contents of that syntax file has the following first few lines

%YAML 1.2
# http: //
name: llvm
scope: source.ll

However when I use the code llvm on a code block I still get the following warning from zola for each code block I use this code on.

Warning: Highlight language llvm not found in blog/

I would have assumed that zola would map llvm to syntaxes/llvm.sublime-syntax, or use the name property of my syntax file to apply the styling. Is there something that I am missing? Is there a way to turn up the debug info on zola build? It doesn’t seem that either RUST_LOG or --verbose are available to see more information about why this might not be working.

After some additional digging I realized that the configuration needs to be in the markdown table, so updating it to

extra_syntaxes_and_themes = ["syntaxes"]

fixed it!


I had the same problem with a custom SystemVerilog.sublime-syntax and it simply would not work, even though I had it in the config.toml file. I think the documentation on the website should reflect this detail, that the extra_syntaxes_and_themes = [“syntaxes”] should be in the [markdown] section of the config.toml file. This was very helpful, thanks.